Defi Wallet Service Unavailable Issue
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 07:29 HKT
Investigating
We are currently investigating an issue with the Defi Wallet displaying service errors
Posted Nov 18, 2020 - 07:24 HKT