Exchange Candlestick and Cancellation Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 29, 2020 - 13:42 HKT
Investigating
We are currently investigating an issue where Exchange candlestick data is delayed.

There have also been some reports of incidents where orders cannot be cancelled -- our team is looking into this.

We apologize for the inconvenience caused.
Posted Aug 29, 2020 - 13:09 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Web Server - Spot/Margin).