EUR Fiat Openpayd deposit/withdraw delays

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 13:41 HKT

Investigating

Our payment provider, OpenPayd, is currently experiencing service disruptions. Consequently, EUR deposits and withdrawals via OpenPayd may be intermittent or delayed.

Deposits: Please pause any planned deposits via OpenPayd until further notice.

Withdrawals: Expect processing delays until service is fully restored.

Recommended Action: We advise using Banking Circle, our backup EUR vendor, for all transactions during this period.
Posted Mar 18, 2026 - 13:40 HKT