Exchange Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 08:39 HKT
Identified
We're entering maintenance mode right now for the exchange to deploy some more fixes - this should be a brief update. Sorry for the interruption.
Posted Jun 23, 2020 - 07:59 HKT
This incident affected: Crypto.com Exchange (API Server, Web Server, Withdrawals).