Trading and Deposit of SHRAP are temporary paused

Incident Report for Crypto.com

Update

We are continuing to monitor for any further issues.
Posted 3 months ago. Dec 24, 2024 - 21:02 HKT

Monitoring

Trading and Deposit of SHRAP are temporary paused
Posted 3 months ago. Dec 24, 2024 - 21:01 HKT