Login and Outage Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 15:00 HKT
Identified
We are experiencing intermittent outages at the network level, our team is working to resolve this as quickly as possible.

We apologize for the inconvenience, and appreciate your patience.
Posted Jul 30, 2020 - 14:16 HKT
This incident affected: Crypto.com App (Main Page, Onboarding) and Crypto.com App Wallet (Buy, Sell).