Crypto.com Visa Cards - Card payment transaction issues

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jun 03, 2024 - 18:06 HKT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2024 - 18:05 HKT

Investigating

We are currently experiencing issues with processing Crypto.com Visa card transactions using (3DS authentication). Please bear with us whilst our teams are investigating.

Top ups to the Visa card is unaffected.
Posted Jun 03, 2024 - 17:05 HKT