Main app/Exchange access issue due to Cloudflare outage

Incident Report for Crypto.com

Resolved

Cloudflare team confirm the issue is resolved
Our services are resumed
Posted Dec 05, 2025 - 17:20 HKT

Update

We are currently working with Cloudflare
Posted Dec 05, 2025 - 17:09 HKT

Investigating

We are currently investigating this issue.
Posted Dec 05, 2025 - 17:07 HKT