VIBAN Account Creation Issues

Incident Report for Crypto.com

Resolved

VIBAN account creation has been restored.
Posted Apr 06, 2020 - 18:45 HKT

Update

VIBAN creation should be restored by Monday, 6 April @ 10 a.m. UTC.
Posted Apr 06, 2020 - 16:22 HKT

Identified

Customers attempting to create VIBAN accounts will encounter an error.

Outstanding VIBAN withdrawals and deposits will be processed at the same time.

We appreciate your patience, and apologize for the inconvenience.
Posted Apr 04, 2020 - 08:48 HKT