Exchange login issue
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Aug 15, 2024 - 14:17 HKT
Investigating
Please note that we are currently experiencing a login issue at Crypto.com Exchange. The following services are impacted:

1. Exchange App and web login
2. Main app balance

We are currently investigating the issue. ETA will be provided once available.
Posted Aug 15, 2024 - 14:04 HKT