Slow Performance on Crypto.com Main app

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 17:46 HKT

Investigating

We are currently experiencing some performance issues on Crypto.com Main app, we're working on it at the highest urgency.
Thank you for your understanding.
Posted Jul 28, 2025 - 17:42 HKT