SGD deposits via SG fast are delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Dec 06, 2024 - 00:57 HKT
Investigating
We are aware of the issue and are currently working with the highest priority. Rest assured that your deposits will be credited very soon.
Posted Dec 05, 2024 - 20:50 HKT