Issue identified with app login and signup
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jun 08, 2024 - 06:53 HKT
Investigating
Login and sign up may be impacted. We are currently investigating this issue.
Posted Jun 08, 2024 - 06:31 HKT