Exchange Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 05:57 HKT
Investigating
We are currently investigating issues with the Exchange, we appreciate your patience and are working hard to resolve the issues.
Posted Sep 16, 2020 - 05:42 HKT
This incident affected: Crypto.com Exchange (Web Server).