Crypto.com Pay for Business - System Maintenance
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jul 07, 2020 - 16:35 HKT
Identified
Crypto.com Pay is undergoing planned maintenance for 6 hours starting 3:00 a.m. UTC, but may vary depending on circumstances.

During the maintenance period, app users will not be able to log in to the Crypto.com Pay Dashboard and accept crypto via Crypto.com Pay Checkout. Moreover, you will not be able to issue invoices.

Please also note that the maintenance is performed on Crypto.com Pay for Business only.

Other Pay services such as Pay Your Friends, Pay Gift Card and Pay Airtime on the Crypto.com App will remain unaffected.
Posted Jul 07, 2020 - 11:09 HKT