Unable to create Sport prediction orders

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 10:15 HKT

Investigating

We are currently experiencing some issues related with Sports prediction orders. Our teams are looking into this issue at the highest urgency. We appreciate your patience and will keep you posted once there is an update.
Posted Mar 15, 2025 - 09:11 HKT