USDC:USD conversion, trading, and deposit
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 05, 2023 - 11:02 HKT
Monitoring
USDC Deposit and Trading services are now restored.
Other USDC-linked services will be progressively restored.
Posted Mar 13, 2023 - 08:45 HKT
Investigating
Out of an abundance of caution, we have temporarily suspended USDC to USD conversion, USDC deposit, and USDC pair trading due to current market conditions. USDC withdrawal remains available.

We will continue to evaluate the situation and plan to resume USDC trading as soon as possible.
Posted Mar 11, 2023 - 12:53 HKT