UAE FIAT deposit delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Dec 31, 2024 - 17:48 HKT
Investigating
Our UAE fiat wallet vendor "Standard Chartered Bank" is having issues processing FIAT (AED, USD) deposits.

Our teams are looking into this issue with our vendors with the highest urgency
Posted Dec 27, 2024 - 11:25 HKT