Banking Circles Fiat Vendor issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 27, 2024 - 22:50 HKT
Monitoring
One of our EURO fiat wallet vendor "Banking Circles" is currently having technical issues:

- New EURO fiat wallet users are advised to use our alternative vendor "OpenPayd" instead.
- Current users on "Banking Circles" will not be able to make new fiat deposit at this moment.
- For existing deposit intention/action through Banking Circle, please pause it and be expected the fund-in will be delayed until BC resume.
Posted Jan 27, 2024 - 19:30 HKT