Issue with Email Verification.
Incident Report for Crypto.com
Resolved
Issue was identified and resolved by our corresponding vendor. We are closing monitoring the situation. Thank you very much for your patience in this.
Posted May 11, 2024 - 12:29 HKT
Investigating
We are aware of a current incident where customers are not receiving email verifications. Teams are working on this urgently and we shall provide status update as soon as we can. Thank you very much for your attention.
Posted May 11, 2024 - 10:48 HKT