App Issues -- Slowness and Errors
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Oct 22, 2020 - 22:23 HKT
Update
We are continuing to investigate this issue.
Posted Oct 22, 2020 - 19:48 HKT
Update
We are continuing our investigation on the slowness issue. Sorry for the inconvenience caused
Posted Oct 22, 2020 - 19:43 HKT
Investigating
We are investigating an issue with the App loading slowly, thank you for your patience
Posted Oct 22, 2020 - 17:56 HKT
This incident affected: Crypto.com App (Main Page, Track Coins, Notifications, Onboarding, Card and Staking) and Crypto.com App Wallet (Buy, Sell, Send, Withdrawals, Deposits).