AUD fiat wallet vendor Monoova Issues

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 18:32 HKT

Investigating

We are currently experiencing issues with our AUD fiat wallet provider, Monoova.
Users may use the alternative AUD vendor "Zai" instead until the service is resumed.
Posted Oct 30, 2025 - 14:43 HKT