Deposits/Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 14:33 HKT
Investigating
Crypto deposits and withdrawals are experiencing delays. We are currently investigating the issue.
Posted Jan 25, 2023 - 14:00 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits), NFT (NFT Withdraw, NFT Deposit), and Crypto.com App Wallet (Withdrawals, Deposits).