Delays with placing UpDown / Strike options and Sports Prediction
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 04:42 HKT
Monitoring
We have identified some delays with placing UpDown / Strike options and Sports prediction. Please bear with us whilst our teams are currently investigating this with the highest priority.
Posted Jan 15, 2025 - 03:33 HKT