Display issue on GBP and EUR on Coin Prices in Main App
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 27, 2023 - 23:54 HKT
Investigating
We are aware of a display issue on GBP and EUR coin prices in the Main App. This is purely a display issue, and teams are working on resolving this urgently. Thank you for your patience.
Posted Nov 27, 2023 - 23:34 HKT