App Slowdowns and Exchange Login Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 05:42 HKT
Investigating
We are aware of users experiencing slowdowns with the app, as well as Exchange logins.

Our team is working on urgently resolving this. Thank you for your patience.
Posted Feb 23, 2021 - 03:16 HKT
This incident affected: Crypto.com App (Main Page) and Crypto.com Exchange (Spot/Derivatives) (Web Server).