App Slowness Issues
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 07, 2021 - 05:10 HKT
Update
App has now entered maintenance mode while we work on restoring our systems. We apologize for the inconvenience.
Posted Jan 07, 2021 - 02:06 HKT
Investigating
We are aware of some intermittent performance issues with the app, and are working to resolve this as soon as possible. Thank you for your patience.
Posted Jan 07, 2021 - 00:44 HKT
This incident affected: Crypto.com App (Main Page).