Intermittent issues with Exchange Web and App

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 16:53 HKT

Update

We are continuing to investigate this issue.
Posted Apr 15, 2025 - 16:53 HKT

Investigating

We are experiencing some intermittent issues with Exchange Web and App due to a temporary network interruption in the AWS data center.

Our teams are looking into this issue with the highest urgency. We appreciate your patience and will keep you posted once there is any update.
Posted Apr 15, 2025 - 16:18 HKT