Exchange Web and App

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 20:41 HKT

Update

Resolved - Exchange withdrawal and deposits are now re-enabled

We are closely monitoring our systems. Please reach out to our CS team via support chat if you encounter any further issues on Exchange.
Posted Jul 18, 2025 - 19:39 HKT

Monitoring

Most issues are now resolved on the Exchange Web and XApp.

Please note Exchange withdrawals and deposits are currently paused whilst we are continuing to stabilise the platform.

We will update again when this is ready.
Posted Jul 18, 2025 - 18:37 HKT

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 14:19 HKT

Update

We are continuing to investigate this issue.
Posted Jul 18, 2025 - 13:35 HKT

Investigating

We are experiencing some intermittent connectivity issues with Exchange Web and App.

Our teams are looking into this issue with the highest urgency. We appreciate your patience and will keep you posted once there is any update.
Posted Jul 18, 2025 - 13:31 HKT
This incident affected: Crypto.com Exchange (API Server, Web Server, Withdrawals, Deposits, Exchange App).