Cash Earn feature is unavailable

Incident Report for Crypto.com

Resolved

The incident has been resolved.
Posted Mar 15, 2026 - 16:35 HKT

Update

Issues on Greendot side have been resolved and the Cash Earn feature is back to normal.
Posted Mar 15, 2026 - 16:34 HKT

Investigating

Please note the Cash Earn feature is temporarily unavailable due to issues on our vendor Greendot. We will let you know once the service resumes.
Posted Mar 15, 2026 - 12:04 HKT