Issues with US ACH Pull Instant Deposit
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 22:41 HKT
Investigating
There is currently an issue with US ACH Pull Instant deposit.

This will impact user's using this fiat payment method for:

- USD Fiat ACH Pull Instant deposit
- USD Fiat ACH Pull instant deposit for Updowns/ Sports prediction and equities

Please be assured your existing deposits are not impacted by this.
Posted Jan 16, 2025 - 22:14 HKT