Paypal US Issues

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 14:29 HKT

Investigating

PayPal is currently unavailable as a payment method for US customers. Please choose an alternative payment option. We apologize for any inconvenience this may cause.
Posted Mar 12, 2026 - 21:04 HKT