Issues with AUD Fiat Wallet Vendor Monoova withdraw/deposits

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted May 01, 2025 - 20:24 HKT

Investigating

Our AUD Fiat Wallet Vendor Monoova its currently experiencing some issues. Until its resolved users will not be able to use Monoova for AUD fiat deposit/withdraw. For now, please use our alternative AUD vendor "Assembly Payments" instead. Will update status once the issue is resolved.
Posted May 01, 2025 - 13:31 HKT