USD Fiat Wallet Issue
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Nov 08, 2021 - 14:24 HKT
Investigating
we are investigating the issues for transactions related to the USD fiat wallet.

Affected transactions include:
USD deposits & withdrawals, Crypto.com Card top ups, crypto purchases

The team is working on resolving this as soon as possible. Thank you for your patience.
Posted Nov 03, 2021 - 10:42 HKT
This incident affected: Crypto.com App Wallet (Fiat Wallets).