Intermittent Issue with SGD Fiat Withdrawal
Incident Report for Crypto.com
Resolved
Withdrawals were observed to be stable. Issue is marked as resolved. Thank you very much for your attention and patience in this.
Posted Jun 15, 2024 - 23:05 HKT
Monitoring
Issue was resolved by our vendor and we observed successful SGD FIAT withdrawals. We continue to monitor the situation.
Posted Jun 15, 2024 - 22:09 HKT
Update
Teams continue to work on the issues with our vendors.
Posted Jun 15, 2024 - 19:43 HKT
Investigating
We are experiencing some intermittent system issues related to SGD fiat withdrawal.

Our teams are looking into this issue with our vendors with the highest urgency. We appreciate your patience and will keep you posted once there is any update.
Posted Jun 15, 2024 - 19:33 HKT