StraitsX (Xfers) Wallet Issues

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Aug 04, 2022 - 20:33 HKT

Investigating

We’re aware of the issue on StraitsX (Xfers) Wallet (Crypto Purchase and Withdrawal). We are actively working with our partners to resolve the issue. Thank you for your patience.
Posted Aug 04, 2022 - 16:59 HKT
This incident affected: Crypto.com App/Web Wallet (Fiat Wallets).