Degraded Performance - Crypto.com Main App

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jul 11, 2025 - 17:36 HKT

Investigating

We are currently experiencing technical issues with the Crypto.com main app that may cause degraded performance for users.

Our technical team is actively working to resolve this issue and restore normal service as quickly as possible.
Posted Jul 11, 2025 - 16:59 HKT