Crypto.com Visa Card Cashback - Delays
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Apr 12, 2021 - 14:11 HKT
Investigating
We are aware of delays with cashback processing for transactions made via the Crypto.com Visa Card. The team is investigating the root cause and once resolved, all cashback transactions will be credited as usual.
Posted Apr 08, 2021 - 18:16 HKT
This incident affected: Crypto.com App (Card and Staking).