Issue with using/adding debit/credit card as payment method

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 22:35 HKT

Monitoring

The card payment service is now recovering. You may still experience some issues.
Posted Nov 18, 2025 - 21:02 HKT

Investigating

We are currently experiencing some issues our vendor which provides card payment service.

This will impact user with using/adding their debit/credit card as payment method within our apps including:

- Google Pay
- Apple Pay

We're working on this and will update you as soon as we can.

Please use other alternative payment methods such as cash wallet.

Operations with using your Crypto.com Debit/Credit card is not impacted by this.
Posted Nov 18, 2025 - 20:01 HKT