Email Provider - Unexpected Outage
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Jul 30, 2020 - 01:59 HKT
Identified
Our email provider is currently experiencing an unexpected outage.

Our teams are working closely with the vendor to get this resolved.

This affects all emails from our systems, including login magic links and transaction notifications.

We apologize for the inconvenience, and appreciate your patience.
Posted Jul 30, 2020 - 01:00 HKT
This incident affected: Crypto.com App (Notifications, Onboarding).