Slow Performance on Crypto.com Main app

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jan 19, 2025 - 20:06 HKT

Monitoring

We have scaled up our systems and most users should not be experiencing slowness anymore. Our team will continue to monitor the situation closely to ensure stability.
Posted Jan 19, 2025 - 18:41 HKT

Investigating

We are currently experiencing some performance issues on Crypto.com Main app, we're working on it at the highest urgency.
Thank you for your understanding.
Posted Jan 19, 2025 - 17:34 HKT