STX Withdrawals Delayed
Incident Report for Crypto.com
Update
We are continuing to monitor for any further issues.
Posted Oct 15, 2021 - 02:25 HKT
Update
We are continuing to monitor for any further issues.
Posted Oct 12, 2021 - 14:08 HKT
Monitoring
STX withdrawals is delayed. We are currently monitoring this issue.
Posted Oct 11, 2021 - 10:55 HKT
This incident affects: Crypto.com App Wallet (Withdrawals, Deposits) and Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits).