RLC Withdrawals Delayed
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 13, 2021 - 14:39 HKT
Investigating
RLC withdrawals are delayed. We are currently investigating this issue.
Posted May 10, 2021 - 09:17 HKT
This incident affected: Crypto.com Exchange (Spot/Derivatives) (Withdrawals, Deposits) and Crypto.com App Wallet (Withdrawals, Deposits).