Card Cashback and Card Balance Updates Impacted

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Sep 12, 2020 - 13:43 HKT

Identified

We are aware of a delay in card cashbacks and card balances being updated. We are working with our partners to resolve this as soon as possible, and appreciate your patience.
Posted Sep 05, 2020 - 22:34 HKT
This incident affected: Crypto.com App/Web (Card and Staking).