UK Crypto.com Exchange Users EDD Form Submission issues

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 09:37 HKT

Investigating

We are aware of an issue preventing UK Crypto.com Exchange users from completing the EDD form, which temporarily restricts trading activity. Our team is working to resolve this with the highest priority.
Posted Jun 26, 2026 - 02:37 HKT