Interac network delays for Payper

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 00:40 HKT

Identified

We are currently observing delays affecting the Interac network for the vendor Payper. As a result, you may notice an increase in pending transactions.

We are actively monitoring the situation and will provide updates as soon as there are any changes.
Posted Apr 06, 2026 - 18:01 HKT