Intermittent Issues with EUR fiat wallet withdrawal
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 14:12 HKT
Investigating
We are currently experiencing intermittent system issues affecting EUR Fiat Wallet Withdrawals.

Our teams are actively looking into this with our vendors and will provide updates as soon as they are available. Thank you very much for your attention.
Posted Mar 06, 2024 - 13:43 HKT