Crypto.com App: Issues with placing Strikes and Updown Options orders
Incident Report for Crypto.com
Resolved
This incident has been resolved.
Posted May 03, 2024 - 16:26 HKT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2024 - 16:24 HKT
Identified
There is currently an issue placing Strikes and Updown Options orders within the Crypto.com App.
Please bear with us whilst the team is working on this.
Posted May 03, 2024 - 16:12 HKT