WBTC Trading, Purchasing and Withdrawals

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted Nov 04, 2020 - 10:37 HKT

Monitoring

Trading, purchasing and withdrawals for WBTC is temporarily paused.
Posted Nov 03, 2020 - 22:40 HKT