Crypto.com Main App Web and Exchange login Issues

Incident Report for Crypto.com

Resolved

This incident has been resolved.
Posted May 01, 2026 - 21:40 HKT

Investigating

We are working hard now to fix this issue. Existing user's who are already logged in are not impacted.
Posted May 01, 2026 - 20:35 HKT